DIY Action Figures - Online

We acknowledge Aboriginal and Torres Strait Islander peoples and their continuing connection to land and as custodians of stories for millennia. We respectfully acknowledge the land on which we all meet today, and pay our respects to elders past, present and emerging.

Duration: 4 workshops, 2hrs each

Delivery method: videoconference + short videos of key skills

First delivered: 2nd, 9th, 16th, 23rd June, 2020

Based on: pop Vinyl Face to Face workshops first delivered in February 2020

Designed by: Billie Ruben

Workshop 1
Posing in Blender
Workshop 2
Modeling in Meshmixer
Workshop 3
Preparing Models for Printing
Workshop 4
Post Processing and Packaging
3D Printing Overview
* why print
* process overview
* How the printer works
* Design tips

Blender
* Why learn Blender?
* Navigation
* Animation tools for posing
* how to pose and save as keyframes
* save project
* export STL
Meshmixer
* Navigation
* Make solid
* Object browser
* meshmixing
* finding and importing models
* combining models
* sculpting
* saving and exporting
Meshmixer
* Overhangs and Support
* Minimum thickness
* Single object
* Manifold
* Cutting model up

PrusaSlicer
* Slicing overview
* Slicing tips
* Checking a slice
Post Processing
* removing supports
* tips on finishing (sand, prime and paint)

Visual Design Principles
* Gestalt (broad overview)
* Limited colours
* text legibility
* similar themes
* visual hirarchy
* grid system
* breathing room/ negative space
* Steal like an artist

Inkscape
* Why Inkscape
* Editing Fill
* Editing Stroke
* Editing fonts
* Making your own shapes

Materials

If your workshop does not require any materials (maybe digital only) delete this section or change to something more appropriate.

Material Quantity Cost Supplier
PLA Filament approx 50g / participant TBA TBA
cardboard (for packaging) 1 A2 sheet per participant TBA TBA
USB memory stick (for software issuing) 1 per participant TBA TBA
Postage (USB memory stick, printed models and boxes) 1 per participant if downloading software, 2 per participant if sending memory sticks TBA TBA

Tools and Preparation

Facilitation Tools

  • Zoom license
  • 3D printer/s
  • Webcam
  • Headset with microphone
  • OBS Studio + VirtuCam2 Plugin (optional)
  • ChromaCam (optional)
  • Laser Cutter
  • 2D Priter

Software & Files

Software/ File Download Link
All files/ Software at time of first delivery Dropbox Link
Autodesk Meshmixer http://www.meshmixer.com/download.html
Blender https://www.blender.org/download/
Inkscape https://inkscape.org/release/inkscape-1.0/
PrusaSlicer https://www.prusa3d.com/prusaslicer/
3D Model Templates 3D Models
Packaging Templates Packaging Templates

Preparation

  1. Advertise and enroll participants
  2. Send them USB stick of all files/software (optional)
  3. Send them an email telling them to either download the files and software from dropbox and install or from USB Stick, have a mouse and second monitor (optional) ready, and give them zoom link to meeting.
  4. Set up and test Zoom.
  5. You can also use OBS to switch easily between various screens and super-impose yourself in front of the content (using ChromaCam), then stream it as a camera to zoom using the VirtuCam2 Plugin for OBS

Workshop Walk through

Below you will find the relevant videos and slides for workshop 1, along with relevant notes/transcripts

Videos

Video Script
Moving your view around your model is really important so that you can see all the different areas of it.
To do that in any 3D program you really need a mouse (a laptop trackpad just doesn’t give you enough functionality).
In Blender;
* You can zoom in and out with your scroll wheel
* You can orbit around your model by holding down on the middle mouse (that’s clicking down on your scroll wheel) and then moving your mouse around
* And you can pan by holding the shift key and your middle mouse down, and then moving your mouse.
* You can also snap to view a certain side of your model by holding down the alt key, your middle mouse button and moving your mouse.
So in blender the key to moving around is really that middle mouse button.
It’s really easy in 3D spaces to be working on something from one angle and think it looks totally fine, only to move to a different angle and realise it’s actually totally wrong
So, it’s a really good idea to constantly zoom out, and move around your object, just to check it’s all hunky-dory
We can change the posture of a rigged model without needing to re-sculpt it, by moving its armature which essentially act like the character’s skeleton.
To start, open your rigged file by going File-Import-FBX
Then, jump into the animation tab
In the dope sheet, move the slider to 10sec
In the 3d viewport click the Show Xray Icon so we can see our armature
Click on one of the bones of the armature and switch to pose mode
From here we can:
* Rotate a bone by hitting R on our keyboard
* Or Translate it by hitting G (this is like moving it)
* Or Scale it using S (this makes it bigger or smaller)
It’s easy to get a bit lost when doing this, so it’s good to make these changes while in orthographic mode, looking side-on at your model, and to move around your model often so you can check that it’s all as you want it.
Once you are happy with the way your model looks, you can store this position as a keyframe by selecting all the bones (by clicking and dragging) then hitting I on your keyboard then LocRotScale, this saves the exact positions of the bones at the current time.
You can also add other positions to this same file by simply moving the timeline along a bit on the dope sheet, and re-positioning the model.
This forms the basis of animation in Blender. If you want to revisit an old position select all the bones and move to the keyframe you wish, then edit the bones as normal.
Once you have edited your model, it’s often handy to be able to come back and edit it later on, or to be able to take it out of Blender so you can use it in a different program.
To do these things we use the Save and Export functions.
To use your model in another program, head to object mode and select the models, then go file>export.
You will see a few different options of file types, what you pick will depend on what you’re doing; for 3D prints, save it as an STL; for videogames, use OBJ; and for rigged files that you want to animate, use FBX.
To save the whole project file so you can come back and edit it later, use File>Save As (remember that any animation poses won’t save unless you’ve added them as keyframes to the Dope Sheet)
Like with any file, it’s a good idea to save your progress regularly, and to save versions before major changes so that you can always go back and revisit your project.

Slides

Slide Notes
workshop1_slide_1_.jpg
workshop1_slide_2_.jpg I would like to respectfully acknowledge all the traditional owners of the land on which the State Library Queensland is situated, and those of each of the areas of land from which we are joining these sessions, virtually.
I would like to recognise their continuing connection to land, water, and community, and pay my respects to their elders; past, present and emerging.
workshop1_slide_3_.jpg
workshop1_slide_4_.jpg We will be hanging out for a few weeks while we learn together, so it will help if we know a bit about each other.
I also want to make sure I’m giving you what you came here for.
workshop1_slide_5_.jpg
workshop1_slide_6_.jpg
workshop1_slide_7_.jpg We will be sending you your 3d prints, and your packaging.
Is your address that you signed up with still valid?
workshop1_slide_8_.jpg Custom Objects
* Like the action figures in this workshops
* Functional things in specific use cases, like little hooks that fit onto your exact picture rails, or a tool (e.g. sewing seam allowance, stencils)
* Personalised gifts etc
* Tabletop gaming (like dungeons and dragons, custom characters & scenery)

Short Runs
* Because it’s not quicker than traditional methods like injection moulding,
* but there’s also no set up cost to run a new design.

Prototyping, Iterating, human-centred design
* Print something, test it, change it, print again.
* Get to properly try things before buying 10,000 and realising no one wants this object.

Rapid Response
* E.G COVID19 PPE shortage: able to make face shields despite supply chains broken/behind because all we needed was filament, no need to set up injection moulding and such which takes several weeks.

Remote Solutions
* Can send file near instantly, and print and use an object, no shipping time/wait
* E.g car part, instead of being imported gets printed when you need one (no waste, no weeks of wait)
* Or space, no need to hobble together solutions, NASA has printer on International Space Station, all they need its it and plastic and they can make many parts and different solutions.

Manufacturing
* Distributed manufacturing, fewer big industrial factories, people can buy or make models and print at home
* Demand-driven just print what’s needed and not more. No manufacturing, shipping holding warehouses of parts/items that may not be sold –eliminates that cost as you can just print as objects are requested
* Lessens environmental impact of industrial manufacture, shipping and storing. We also use a material called PLA which is made from reenable resource (mostly corn) and recyclable –same stuff Woodford folk festival use on their food containers
workshop1_slide_9_.jpg Digital 3D object into physical one, like a paper printer turns 2D digital into physical.

3D Printing aka Additive Manufacturing = Adding material to object as opposed to subtractive like CNC router, laser cutter, lathe
workshop1_slide_10_.jpg Many different 3D printing technologies, easiest to start FDM/FFF due to price, safety

Fused Deposition Modeling (FDM), or Fused Filament Fabrication (FFF)
* FDM/ FFF is essentially:
* A hot glue gun that moves around,
* building the shape layer by layer, on top of itself
* instead of glue sticks uses plastic string called filament
workshop1_slide_11_.jpg
workshop1_slide_12_.jpg Model –Download (from many sites online) or make one (like we are!)
Slice -Turns model into instructions for printer
Print –Using machine (and troubleshoot!) –It’s still hard bringing digital into real, like 2D paper printers still jam all the time, and 3D printers just add more complexity. So there is an element of troubleshooting.
Post-Process -Remove supports, sand and paint (if you want to!, I quite like the look of raw. You can also do fun things like add gold leaf)
workshop1_slide_13_.jpg Slicer software takes 3d model
Cuts it up into thin layers like hundreds of cross sections
Then draws out the picture of each cross section in lines
These lines get turned into coordinates that the printer moves to and squeezes out plastic between.
Prints layer by layer, from bottom to top, each layer is like a big linework picture, stacked on top of the previous
So the printer doesn’t “know” what it’s printing. It just has a list of numbers, essentially.
Builds upon itself. Can’t start mid air
workshop1_slide_14_.jpg So, because it builds from the bottom up, on top of itself this means it can’t print things in mid air, it needs material underneath.
This applies too, to steep overhangs: ones that stick out more than 45 degrees.
We can add support material, but it can make parts look not as pretty because there’s a careful balance between having enough material for the part to build on, while also being able to remove it…
Thankfully we can design away a lot of the need for them in the design stage…
workshop1_slide_15_.jpg Here are some examples. The red areas would need support, because they either start over nothing or have steep overhangs.
But we could fix some of these! We could attach the giraffes tail to it’s back leg, so it was resting on the body, and we could have its head and ears facing up.
Its belly is a bit unavoidable, unless we cut the model into two, horizontally and print both halves then glue them back together later.

On the woman the arms head and hem of the skirt all start over nothing, so we would need to add support in the slicer.
Similar with the jumping person, on their head, leg, arm and stars.

Interestingly the super hero is pretty good though, all these angles are about 45 degrees.
The hand on the folded arm seems to be resting on the hip, so it doesn’t need support, both feet start on the ground,
and it looks like that cape either starts at the floor or the leg, though it could be a little thin…
workshop1_slide_16_.jpg Because we are squeezing out a line of plastic that isn’t infinitely thin, some detail won’t be possible, so it’s important to keep all parts a bit chunky.
Thin bits either wont print, or will break off later.
workshop1_slide_17_.jpg I’ve also made a poster with more tips, mostly tailored at less organic shapes/ more functional ones, but they still hold true.
Full-res version here: https://imgur.com/gallery/SqIdFwB
workshop1_slide_18_.jpg
workshop1_slide_19_.jpg Can do almost anything in 3D pipeline: modeling, rigging, animation, simulation, image editing, rendering, scripting, compositing, motion tracking, video editing and game creation.
One of the only free/good animation/posing software
Note: 2.8 is very different (lots better) than previous versions, especially in the user interface and learnability, so if you've tried it before and hated it (like me!) it's worth trying again now. :)
workshop1_slide_20_.jpg
workshop1_slide_21_.jpg Armature is like a skeleton, its bones are like our bones, we can move them to change the shape of the model.
workshop1_slide_22_.jpg Animation tab: posing is usually used in animation, so we will be using a lot of animation tools in Blender
Dope sheet move slider to 10 sec: dope sheet is where we would normally set keyframes which is like the main positions in an animation. We’re using the sheet here just to save our poses (if we don’t, they disappear when we go to save it)
3D Viewport> Show x-ray
Click bones> pose mode
workshop1_slide_23_.jpg
workshop1_slide_24_.jpg Remember to snap views
Notice pinching, we will fix next week, this is just rough
workshop1_slide_25_.jpg Select all bones
I>LocRotScale (saves a keyframe =this pose at this point in time including all the rotations, locations and sizes of each selected bone- hence LocRotScale)
Can save more poses more just by moving the slider along the timeline and doing some more (need to select bones
Save As to save this project to edit it
Object Mode
Export STL
workshop1_slide_26_.jpg
workshop1_slide_27_.jpg If you intend in selling items you've downloaded (or derivatives of them) in future, check that the license allows for it.
workshop1_slide_28_.jpg
workshop1_slide_29_.jpg
workshop1_slide_30_.jpg
workshop1_slide_31_.jpg

Below you will find the relevant videos and slides for workshop 2, along with relevant notes/transcripts

Videos

Video Script
In Meshmixer, you can start a new file in various different ways, depending on what you’re doing.
* If you’re starting a new sculpture totally from scratch, you might want to start with a sphere, it will be sort of your lump of clay at the beginning.
* If you are opening a file you’ve previously worked on in Meshmixer you will want to use the open function, and find your file.
* Similarly, if you want to edit a model that you already have (say you downloaded one from the internet), you can use the import function, which will bring your model in and start a new Meshmixer file.
* For now I’m going to Import this bunny model, so I can show you around.
So once you are in Meshmixer, you will see your object. And you can move around this 3d space in various ways.
* You can Pan across the current plane by clicking and holding down your central mouse button, (that’s the scroll wheel on your mouse), and moving your mouse it around.
* You can Orbit or Tumble around your model by holding down right mouse button and moving your mouse around.
And you can Zoom in and out with your mouse wheel or by pressing ALT, holding down the right mouse button and moving your mouse.
* When you get lost, like say you end up way inside here and you’re like “Where am i?” you can click on View-Recenter View and it will snap you back out, so you can see your full model again.
* It’s also good to take note of the cube up in the top right corner, as it will give you an indication of what part of your model you are looking at.

If you forget any of these there is a Keyboard shortcut document when you first start up mesh mixer, that has all of these listed (and more!)
Holes, such as this one at the bottom of this Stanford bunny are not ideal,
because when we to generate the 3D printing file the slicing software can’t tell what’s inside the model and what’s outside,
and this can create some pretty severe errors

To prevent this we use the made solid function, which fills these holes and sorts out any weird bits of geometry for us

Click on the object to select it
Edit>make solid
From this menu we can change the mesh density, which allows us to preserve or remove detail,
so if I bring this right down and hit update, it will make a very choppy bunny,
and if I bring it back up, make it smoother, like my original,
So it’s a good one to play with that one, just to ensure you're not losing any detail when you go through this function.
Once you’re happy with it, hit accept, and it will show that it has filled in the bottom.
You’ll end up with 2 separate objects in your objects browser, one that says solid and one that doesn’t say solid
So if you want to you can now delete this old one so you’re just keeping the solid one

You can use the make solid function to repair things like 3d scans, and objects you download from online.
This is especially handy if the objects were not originally made for printing, like, for instance they were made for a videogame.
It’s also good practice to do it regularly to any file you’ve
If you have a bunch of objects in your scene it can get a bit cluttered, and this can make it really hard to edit a single model.
Thankfully, we can make certain objects invisible through the object browser
To do so, go View> show objects browser.
From here we can select objects by clicking on them in this menu. Notice how the selected object is lighter in the scene and darker in the menu, when selected.

We can use these eye symbols next to the objects to toggle their visibility.
You’ll notice that when I toggle the object that I also have selected, in this case the bunny, you get this x-ray effect.
To stop seeing this you can click another object.

You also might want to entirely remove an object from your scene, so that you can no longer make it visible again, and its no longer part of your file.
To do this, select the object and hit the garbage can icon in the bottom right to delete it.
You’ll notice it has disappeared from the browser and our scene.
To join 2 objects together you first have to add them to your scene, then resize and move them into place, and finally, combine them.

To get started, click the import button, then append. Then double click the object you want and it will be added to your scene.
To move it into place, first click on it to select it (it will turn light grey), then go Edit>transform.
From here we can:
* Move the object by clicking and dragging the directional arrows
* We can rotate it clicking and dragging these arcs
* and we can make the whole object bigger or smaller by clicking the centre cube and dragging our mouse left or right.

As with all edits in 3d space, it’s good to look around your model often to check everything is where you want it.
Once you’re happy with it, hit ‘Accept’.

Now, to join these models together into one form,
start with one of them selected then hold down shift on your keyboard and click the other, so that you now have both selected in light grey,
then click Boolean union, wait for it to process, then click accept.
You will see they’re now the same object in the object browser.

If you’re combining a model for 3D printing, it’s a good idea to check that things like hats are already filled in on the inside,
as this can lead to complications when you go to print it.
For instance it would have been good to fill this hat with a cone shape,
and combining those with a Boolean union first,
before joining it to our figure, to eliminate this hole in the centre.
There are lots of models online, but sometimes we want to make our own, or to make changes to models that we find.
We can make some of these changes in Meshmixer using the Sculpt tools.

This allows us to edit our models as though they were made out of a digital form of clay.

Click on the object you wish to edit, and then click sculpt.
From here we can access the brushes menu, which gives us an array of tools to try.
Each brush is used by clicking and dragging on the model to ‘paint’ with that effect.
The Draw tools add bulk to the areas they’re used.
You can make a brush bigger or smaller using the size slider.
The Drag tool allows you to grab and pull an area of the model.
The Pinch tool makes little peaks along your model.
And the Robust Smooth tool allows you to even out areas.
There are a few more types of brushes, so feel free to have a play with those, as well as the sliders under properties, to change different features of the brushes.

It’s easy when using the sculpt tools to introduce strange geometry, so it’s good to use the make solid function every now and then, because it fixes any weird bits.

You also don’t need to start with an existing model, you can use a simple sphere to begin with, and build a model totally from scratch using these sculpting tools.

Sculpting is also just one way to edit a model.
For less organic, more structured items like say a building, or a table, you might like to use something like TinkerCAD instead of Meshmixer.
For real-life functional items, with strict dimensions and parameters, for example something like a tool, you might want to try some proper CAD software like Fusion 360.
Once you have edited your model, it’s often handy to be able to come back and edit it, again, later on,
or to be able to take it out of Meshmixer so you can use it in a different program, for example your slicing software for 3D printing.

To do these things we use the Save and Export functions.

To use your model in another program, click on the object you want and go file>export.
For 3D prints, save it as an STL ASCII Format.
Give it a name and hit save.
This process will only export the selected model, so if you want to export more than one, it’s recommended you combine them first using the Boolean Union.

To save the whole project file so you can come back and edit it later, use File>Save As

Like with any file, it’s a good idea to save your progress regularly, and to save versions before you make major changes so that you can always go back and revisit it.

Slides

Slide Notes
workshop2_slide1.jpg
workshop2_slide2.jpg
workshop2_slide3.jpg He runs The Edge!

Daniel introduce himself. Talk a bit about the Edge
workshop2_slide4.jpg
workshop2_slide5.jpg Now that you’ve had some time to make a pose, it’s time to show them off!
Let’s go around the group and each person shows their models

This week we will do a lot of sharing, so that I can see what you’re working on and so that we can all learn from each other.
workshop2_slide6.jpg
workshop2_slide7.jpg In Meshmixer, you can start a new file in various different ways, depending on what you’re doing.
* If you’re starting a new sculpture totally from scratch, you might want to start with a sphere, it will be sort of your lump of clay at the beginning.
* If you are opening a file you’ve previously worked on in Meshmixer you will want to use the open function, and find your file.
* Similarly, if you want to edit a model that you already have (say you downloaded one from the internet), you can use the import function, which will bring your model in and start a new Meshmixer file.
* For now I’m going to Import this bunny model, so I can show you around.
So once you are in Meshmixer, you will see your object. And you can move around this 3d space in various ways.
* You can Pan across the current plane by clicking and holding down your central mouse button, (that’s the scroll wheel on your mouse), and moving your mouse it around.
* You can Orbit or Tumble around your model by holding down right mouse button and moving your mouse around.
And you can Zoom in and out with your mouse wheel or by pressing ALT, holding down the right mouse button and moving your mouse.
* When you get lost, like say you end up way inside here and you’re like “Where am i?” you can click on View-Recenter View and it will snap you back out, so you can see your full model again.
* It’s also good to take note of the cube up in the top right corner, as it will give you an indication of what part of your model you are looking at.

If you forget any of these there is a Keyboard shortcut document when you first start up mesh mixer, that has all of these listed (and more!)
workshop2_slide8.jpg Edit>Make Solid Object browser window will open now two bunnies, old one and new one. Explain Visibility and selection in Objects browser

—- Holes, such as this one at the bottom of this Stanford bunny are not ideal,
because when we to generate the 3D printing file the slicing software can’t tell what’s inside the model and what’s outside,
and this can create some pretty severe errors
To prevent this we use the made solid function, which fills these holes and sorts out any weird bits of geometry for us

Click on the object to select it
Edit>make solid
From this menu we can change the mesh density, which allows us to preserve or remove detail,
so if I bring this right down and hit update, it will make a very choppy bunny,
and if I bring it back up, make it smoother, like my original,
So it’s a good one to play with that one, just to ensure you're not losing any detail when you go through this function.

Once you’re happy with it, hit accept, and it will show that it has filled in the bottom.
You’ll end up with 2 separate objects in your objects browser, one that says solid and one that doesn’t say solid
So if you want to you can now delete this old one so you’re just keeping the solid one

You can use the make solid function to repair things like 3d scans, and objects you download from online.
This is especially handy if the objects were not originally made for printing, like, for instance they were made for a videogame.
It’s also good practice to do it regularly to any file you’ve been working on for a long while, just to make sure you haven’t accidentally introduced any weird geometry along the way.


If you have a bunch of objects in your scene it can get a bit cluttered, and this can make it really hard to edit a single model.
Thankfully, we can make certain objects invisible through the object browser
To do so, go View> show objects browser.
From here we can select objects by clicking on them in this menu. Notice how the selected object is lighter in the scene and darker in the menu, when selected.

We can use these eye symbols next to the objects to toggle their visibility.
You’ll notice that when I toggle the object that I also have selected, in this case the bunny, you get this x-ray effect.
To stop seeing this you can click another object.

You also might want to entirely remove an object from your scene, so that you can no longer make it visible again, and its no longer part of your file.
To do this, select the object and hit the garbage can icon in the bottom right to delete it.
You’ll notice it has disappeared from the browser and our scene.
workshop2_slide9.jpg Meshmix: Select object you want to add to. Select thing you want to add, hover over surface and click. Adding in another STL: download it.
Import>append
Move it into place> Accept shift select both>combine Make solid

—-

To join 2 objects together you first have to add them to your scene, then resize and move them into place, and finally, combine them.

To get started, click the import button, then append. Then double click the object you want and it will be added to your scene.
To move it into place, first click on it to select it (it will turn light grey), then go Edit>transform.
From here we can:
* Move the object by clicking and dragging the directional arrows
* We can rotate it clicking and dragging these arcs
* and we can make the whole object bigger or smaller by clicking the centre cube and dragging our mouse left or right.

As with all edits in 3d space, it’s good to look around your model often to check everything is where you want it.
Once you’re happy with it, hit ‘Accept’.

Now, to join these models together into one form,
start with one of them selected then hold down shift on your keyboard and click the other, so that you now have both selected in light grey,
then click Boolean union, wait for it to process, then click accept.
You will see they’re now the same object in the object browser.

If you’re combining a model for 3D printing, it’s a good idea to check that things like hats are already filled in on the inside,
as this can lead to complications when you go to print it.
For instance it would have been good to fill this hat with a cone shape,
and combining those with a Boolean union first,
before joining it to our figure, to eliminate this hole in the centre.
workshop2_slide10.jpg Show them the tools, let them play for most of the rest of the time, bring people together 20mins before end

—-


There are lots of models online, but sometimes we want to make our own, or to make changes to models that we find.
We can make some of these changes in Meshmixer using the Sculpt tools.

This allows us to edit our models as though they were made out of a digital form of clay.

Click on the object you wish to edit, and then click sculpt.
From here we can access the brushes menu, which gives us an array of tools to try.
Each brush is used by clicking and dragging on the model to ‘paint’ with that effect.
The Draw tools add bulk to the areas they’re used.
You can make a brush bigger or smaller using the size slider.
The Drag tool allows you to grab and pull an area of the model.
The Pinch tool makes little peaks along your model.
And the Robust Smooth tool allows you to even out areas.
There are a few more types of brushes, so feel free to have a play with those, as well as the sliders under properties, to change different features of the brushes.

It’s easy when using the sculpt tools to introduce strange geometry, so it’s good to use the make solid function every now and then, because it fixes any weird bits.

You also don’t need to start with an existing model, you can use a simple sphere to begin with, and build a model totally from scratch using these sculpting tools.

Sculpting is also just one way to edit a model.
For less organic, more structured items like say a building, or a table, you might like to use something like TinkerCAD instead of Meshmixer.
For real-life functional items, with strict dimensions and parameters, for example something like a tool, you might want to try some proper CAD software like Fusion 360.
workshop2_slide11.jpg Remember to try and design away overhangs, and to ensure things are kept a bit chonky.
workshop2_slide12.jpg File>save as; to save the whole file.

View wireframe by hitting W, these lines all the little triangles that make up this model.
We refer to the triangles as polygons or polys for short.
The more polys, the more detail and the larger file size.
If we have too many polys they make our printer travel really slowly and sort of stutter a bit, as it makes lots of tiny moves.
This leads to lower quality, and longer print times, so it’s good to have a balance between detail and the number of polys.

To export for printing or to take it into another software
click on model, file>export
Choose STL (ACSII Format)

—-

Once you have edited your model, it’s often handy to be able to come back and edit it, again, later on,
or to be able to take it out of Meshmixer so you can use it in a different program, for example your slicing software for 3D printing.

To do these things we use the Save and Export functions.

To use your model in another program, click on the object you want and go file>export.
For 3D prints, save it as an STL ASCII Format.
Give it a name and hit save.
This process will only export the selected model, so if you want to export more than one, it’s recommended you combine them first using the Boolean Union.

To save the whole project file so you can come back and edit it later, use File>Save As

Like with any file, it’s a good idea to save your progress regularly, and to save versions before you make major changes so that you can always go back and revisit it.
workshop2_slide13.jpg We’ve only done one kind of model making today, There are other kinds suited to different tasks.
workshop2_slide14.jpg
workshop2_slide15.jpg
workshop2_slide16.jpg

Below you will find the relevant videos and slides for workshop 3, along with relevant notes/transcripts

Videos

Video Transcript
Sometimes you might want to cut one object out of another, for example to make a simple base stand for a model.

Here we have our model, and her feet are placed just a little way into this cylinder.
It's easiest to see when the cylinder is in x-ray view.

I want to cut the feet shape our of the cylinder, so I’ve placed them overlapping each-other.
To make the cut first select the object you want to cut from, then hold shift and click the object you want to cut out of that first shape.
Then select Boolean difference, and hit accept.

And there we have it!

Because this function deletes the object you’re cutting, you might want to first duplicate it using the option in the object browser, then perform the cut.
To make a 3D Print we first have to slice our 3D model into instructions called GCODE, which our printer can read.
The Gcode is essentially a set of coordinates telling it where to move the nozzle, how much plastic to push out, and what temperatures to do so.

To slice your model into gcode in PrusaSlicer, click the add icon and open your 3D model
We can change the size of the model in the object manipulation panel.
Z is the vertical axis. Let’s change its size to 100mm (so that our model is 10cm in height).
For a character like this it’s also a good idea to tilt the model backwards so most support ends up behind the model. To do this change the rotation on the X axis to -45

The print settings change a lot of settings in the background but the main one is the layer height (which is that number in the title).
The smaller the layer height, the longer the print and usually the less visible the layer lines.
We’re going to use 0.2 as it’s a good balance between print time and surface finish.
The printers we have in the Fabrication Lab at The Edge are Prusa MK3S, so let’s pick that.
We want supports everywhere, so nothing is left hanging.
Infill of 15% is good for this model,
And we will turn the brim on, which will help ensure the model sticks to the bed.

Once that’s done we can hit Slice Now, and generate our GCODE.
It will give us this preview. It’s a good idea to scroll through the layers and check that no parts of the model are starting over nothing, that there is a large surface touching the bed, and that the orange part looks like our model should.
Once you are happy, hit export Gcode. These are the instructions we will load onto our machine.
It’s also a good idea to save the project, in case we want to come back and change some settings if our print fails.

We’re using an abbreviated view here, based on the settings that work best for most people most of the time, but slicer settings go deep! There’s a lot more info about this printer and slicer on prusa3d.com.

Slides

Slide Notes
workshop3_slide_1_.jpg
workshop3_slide_2_.jpg
workshop3_slide_3_.jpg
workshop3_slide_4_.jpg
workshop3_slide_5_.jpg Single object> check object browser

Manifold> use make solid (Up accuracy)
workshop3_slide_6_.jpg
workshop3_slide_7_.jpg
workshop3_slide_8_.jpg Sometimes you might want to cut one object out of another, for example to make a simple base stand for a model.

Here we have our model, and her feet are placed just a little way into this cylinder.
It's easiest to see when the cylinder is in x-ray view.

I want to cut the feet shape our of the cylinder, so I’ve placed them overlapping each-other.
To make the cut first select the object you want to cut from, then hold shift and click the object you want to cut out of that first shape.
Then select Boolean difference, and hit accept.

And there we have it!

Because this function deletes the object you’re cutting, you might want to first duplicate it using the option in the object browser, then perform the cut.
workshop3_slide_9_.jpg
workshop3_slide_10_.jpg Slicer software takes 3d model
Cuts it up into thin layers like hundreds of cross sections
Then draws out the picture of each cross section in lines
These lines get turned into coordinates that the printer moves to and squeezes out plastic between.
Prints layer by layer, from bottom to top, each layer is like a big linework picture, stacked on top of the previous
So the printer doesn’t “know” what it’s printing. It just has a list of numbers, essentially.
Builds upon itself. Can’t start mid air
workshop3_slide_11_.jpg Smaller Layer height=higher quality due to less visible lines, more opportunity for detail, but makes print take a lot longer.
0.2mm is a happy median

Infill holds up top surfaces. 15% is a good amount for non functional parts

Slower=better quality because there’s less inertia at sharp angles and so less wobbling.
workshop3_slide_12_.jpg To make a 3D Print we first have to slice our 3D model into instructions called GCODE, which our printer can read.
The Gcode is essentially a set of coordinates telling it where to move the nozzle, how much plastic to push out, and what temperatures to do so.

To slice your model into gcode in PrusaSlicer, click the add icon and open your 3D model
We can change the size of the model in the object manipulation panel.
Z is the vertical axis. Let’s change its size to 100mm (so that our model is 10cm in height).
For a character like this it’s also a good idea to tilt the model backwards so most support ends up behind the model. To do this change the rotation on the X axis to -45

The print settings change a lot of settings in the background but the main one is the layer height (which is that number in the title).
The smaller the layer height, the longer the print and usually the less visible the layer lines.
We’re going to use 0.2 as it’s a good balance between print time and surface finish.
The printers we have in the Fabrication Lab at The Edge are Prusa MK3S, so let’s pick that.
We want supports everywhere, so nothing is left hanging.
Infill of 15% is good for this model,
And we will turn the brim on, which will help ensure the model sticks to the bed.

Once that’s done we can hit Slice Now, and generate our GCODE.
It will give us this preview. It’s a good idea to scroll through the layers and check that no parts of the model are starting over nothing, that there is a large surface touching the bed, and that the orange part looks like our model should.
Once you are happy, hit export Gcode. These are the instructions we will load onto our machine.
It’s also a good idea to save the project, in case we want to come back and change some settings if our print fails.

We’re using an abbreviated view here, based on the settings that work best for most people most of the time, but slicer settings go deep! There’s a lot more info about this printer and slicer on prusa3d.com.
workshop3_slide_13_.jpg
workshop3_slide_14_.jpg
workshop3_slide_15_.jpg https://drive.google.com/drive/folders/1pGOaIuuPEHxHWbY1Ct2bj0JIvK50F9LP?usp=sharing
workshop3_slide_16_.jpg
workshop3_slide_17_.jpg
workshop3_slide_18_.jpg

Below you will find the relevant videos, slides and files for workshop 4, along with relevant notes/transcripts

Videos

Video Transcript
Adding simple shapes often makes up the foundation of a graphic.

To start, click on the rectangle tool on the left hand bar,
then click and drag it to make a rectangle on your screen.

You can hold down ctrl key and drag at roughly a 45* angle from your start point to force the rectangle to be a square.

Similar with the oval tool, you can hold down control to force it to be a circle.
You can also make pac-man shapes by changing the start an d end degrees of a circle.

Holding down control while using the polygon tool snaps the corner you’re drawing out to an angle increment of 15 degrees, Which allows you to snap things to be vertical or horizontal.
You can also change the number of corners of a polygon using this box.

Once you have a shape you can move it by clicking the select icon and then clicking and dragging the object, and releasing it when you have it in a spot you like.
When moving you can snap corners to other corners by hovering them near each other until this “corner to corner” tooltip appears.

We can also resize our object using these arrows….
and we can click on the object again to bring up rotate…
and skew tools.

To de-select an object click somewhere that’s blank on the canvas
To change the colour of a selected object we can click on a pre determined colour from this palette at the bottom of the screen

but if we want to choose a colour that isn’t listed here,
we need to open the fill and stroke tool from the object menu.

The fill is the main colour of the shape.
To change it click on the flat colour icon,
and change the colour mode to Wheel.
from here we can change the colour by clicking and dragging the little bar on the rainbow ring,
and the circle within the triangle.
We can also make the colour transparent using this alpha bar.

If we want to give our object a gradient, we can do so using the linear gradient icon.
We can also edit the gradient by clicking on this icon.
From here we can change a colour in our gradient by clicking on the point and changing it using the wheel or a swatch.
We can add more colours to our gradient by double clicking anywhere on the gradient line and editing that dot lie we did the beginning and end dots.
We can also change the direction of the gradient by clicking and dragging these points at the end of the line
When we are happy with our gradient click off our object to set it.


We can add boarders to our objects. These are called Strokes. To add one, select your object
Then head to the Stroke Paint menu and click the Flat colour icon. You can pick a colour for it here.

You can change various aspects of the line in the stroke style menu, like the width… dashes…. and corner type.


This allows you to really make objects look and feel your own.
Sometimes you want a graphic you can’t find, and thankfully Inkscape offers a few ways to make your own.

The simplest way is by using multiple primitive shapes to create more complex new ones,
which you can do via various options listed under the Path menu
You can combine shapes using union
You can cut one shape from the another by selecting the one you want to keep,
then shift-clicking the one you want to remove and using difference
You can keep just the area that two shapes overlap using intersection
Or just the bits they don’t overlap using exclusion
You can also use one shape to cut parts of another shape
So you can more or recolour segments of it using division.

You can combine these methods to build up some pretty complex forms, but if you want even more flexibility it’s time to look at Bezier curves.
With this tool you can draw straight lines by left clicking to form your first point,
then clicking again to form your first line,
and again to form another, connected line.
You can also make curves by clicking and dragging a new point, then releasing your mouse when you like the curve.
And you can close a shape by clicking the first point once more.

You can also edit your shape using the node edit tool.
We can now click on these points and move their handles.
You’ll notice we can now move one handle to be long and one short,
which allows us to further refine our shapes.
But say we have a curve here but we want a corner.
We can change it using this button. I can now drag this handle to make a corner.
Similarly we can convert corners to straights again using this option, or to equal straight using this one.

If you have a hand drawn picture you can scan that in and import it, then trace over it with a Bezier curve to make your graphic.
That can be a good way to get a feel for things when you’re just starting out wit Bezier curves.

Slides

Slide Notes
Removing support – peel off by hand, scalpel handy at times.
Sanding –by hand, wet, with mask, machine sanding will melt the plastic. Mini files are handy!
Filing –Spray automotive filler great (Acrylic)
Priming & Painting (Acrylic). Painting minis goes deep, lots of tutorials on YouTube!
More colours = more complex, more mess. 4 or fewer
Include dark and light (for readability)
Avoid “pure” colours (or have only one)
Help:
Coolers.co (randomised, and browsable)
Colour.adobe.com (different methods of colour palette making)
Keep text a lot darker or lighter than background
Pick a legible font
Don’t make fonts too small, remember to think about your object in the size of the real world
If you are going to use graphics in your images, ensure you are using ones that have the right copyright
And try to keep them the same overall theme. If you are using things without lines, and some with, and some real images and some icons, the whole amalgamation can look garish.
This example is borderline, even though each cube has almost a full cube space between it and the next it’s still quite cluttered.
These tool heads are a bit better as an example. They stand out more because they as a cluster have a lot of space around them, and there is enough space between them for them to stand alone as individuals too. It’s clean and comfortable.
Creativity isn’t about coming up with totally new ideas.
Creativity is about mashing bits of knowledge together to form something new.
When we experience something new, the knowledge is fed a few times between short and long term memory while our brains work out where to index new knowledge so it can store it somewhere to use later.
As travels this path, it actually literally scrambles through our existing memories, through the rest of our knowledge it bumps into other ideas, and it’s these intersections of ideas where creativity happens.

If’ you’re into 3D printing you might find inspiration in woodworking, as an example, because they both have grain lines, so your brain might try to relate them to each other, and then you might find that some of the knowledge you have from woodworking applies to 3D printing, like for example that the strength of a object produced by a 3D printer is determined by the direction of the grain line. And thinking on that more you might start to see other opportunities, like that you could use traditional no-nail wood joints to join 3D printed parts without glue. And as you dwell there on the overlap between ideas you will find more and more. A woodworking sanding bow can be used to easily sand 3D prints, I wonder if I could 3D Print a woodworking bow?

So it’s this iterative process of getting a new idea and mooshing it together with existing knowledge.
These intersections of concepts and the ideas therein are where the ‘magic’ of creativity happens.

And knowing this is great, because it means that we can influence our own creativity. It’s not some divine, ethereal power some people are blessed with and others not. The more information you're gathering and the less familiar that information is, the more your brain scrambles thoughts, and the more likely you are to come up with a creative idea.

So, when you’re making a new packaging design, you don’t’ need to start with nothing, take a look at packages of brands you already like, find colours you like from a favourite pillow at home, find little decorative elements that aren’t even from print, like all the beautiful wood cuts we have on traditional Queenslander-style houses, as an example.

And feel free to google! I also really like sites like Pinterest, that allow me to collect images under headings. My 3D printing board is filled with embroidery, fish scales, art nouveau jewelry, book binding jigs, sanding bows, old alleyways, military medals, polly pockets, images of cracked surfaces… All kinds of things, all that inspire my 3D printed works and almost none of them that are actually 3D printed.

Find things you like, a moosh them together. 

You feed more in, you get more out.
Vector Graphics
Lines not pixels = super crisp prints at any size
Suited to graphics (like packaging, poster etc, not photo manipulation like photoshop is)

Free & Open Source
Adding simple shapes often makes up the foundation of a graphic.

To start, click on the rectangle tool on the left hand bar,
then click and drag it to make a rectangle on your screen.

You can hold down ctrl key and drag at roughly a 45* angle from your start point to force the rectangle to be a square.

Similar with the oval tool, you can hold down control to force it to be a circle.
You can also make pac-man shapes by changing the start an d end degrees of a circle.

Holding down control while using the polygon tool snaps the corner you’re drawing out to an angle increment of 15 degrees, Which allows you to snap things to be vertical or horizontal.
You can also change the number of corners of a polygon using this box.

Once you have a shape you can move it by clicking the select icon and then clicking and dragging the object, and releasing it when you have it in a spot you like.
When moving you can snap corners to other corners by hovering them near each other until this “corner to corner” tooltip appears.

We can also resize our object using these arrows….
and we can click on the object again to bring up rotate…
and skew tools.

To de-select an object click somewhere that’s blank on the canvas
To change the colour of a selected object we can click on a pre determined colour from this palette at the bottom of the screen

but if we want to choose a colour that isn’t listed here,
we need to open the fill and stroke tool from the object menu.

The fill is the main colour of the shape.
To change it click on the flat colour icon,
and change the colour mode to Wheel.
from here we can change the colour by clicking and dragging the little bar on the rainbow ring,
and the circle within the triangle.
We can also make the colour transparent using this alpha bar.

If we want to give our object a gradient, we can do so using the linear gradient icon.
We can also edit the gradient by clicking on this icon.
From here we can change a colour in our gradient by clicking on the point and changing it using the wheel or a swatch.
We can add more colours to our gradient by double clicking anywhere on the gradient line and editing that dot lie we did the beginning and end dots.
We can also change the direction of the gradient by clicking and dragging these points at the end of the line
When we are happy with our gradient click off our object to set it.
We can add boarders to our objects. These are called Strokes. To add one, select your object
Then head to the Stroke Paint menu and click the Flat colour icon. You can pick a colour for it here.

You can change various aspects of the line in the stroke style menu, like the width… dashes…. and corner type.


This allows you to really make objects look and feel your own.
Sometimes you want a graphic you can’t find, and thankfully Inkscape offers a few ways to make your own.

The simplest way is by using multiple primitive shapes to create more complex new ones,
which you can do via various options listed under the Path menu
You can combine shapes using union
You can cut one shape from the another by selecting the one you want to keep,
then shift-clicking the one you want to remove and using difference
You can keep just the area that two shapes overlap using intersection
Or just the bits they don’t overlap using exclusion
You can also use one shape to cut parts of another shape
So you can more or recolour segments of it using division.

You can combine these methods to build up some pretty complex forms,
With this tool you can draw straight lines by left clicking to form your first point,
then clicking again to form your first line,
and again to form another, connected line.
You can also make curves by clicking and dragging a new point, then releasing your mouse when you like the curve.
And you can close a shape by clicking the first point once more.

You can also edit your shape using the node edit tool.
We can now click on these points and move their handles.
You’ll notice we can now move one handle to be long and one short,
which allows us to further refine our shapes.
But say we have a curve here but we want a corner.
We can change it using this button. I can now drag this handle to make a corner.
Similarly we can convert corners to straights again using this option, or to equal straight using this one.

If you have a hand drawn picture you can scan that in and import it, then trace over it with a Bezier curve to make your graphic.
That can be a good way to get a feel for things when you’re just starting out wit Bezier curves.
  • workshops/prototypes/diy_action_figure.txt
  • Last modified: 2020/07/01 10:47
  • by Billie Ruben